Quantcast

Re: Errors faced trying to get Mondrian working with Lucid DB(0.92) using FOODMART schmea

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors faced trying to get Mondrian working with Lucid DB(0.92) using FOODMART schmea

Tom Barber
Hi Richard,

I have no experience setting up Lucid solely with JPivot, but i can tell you without a shadow of a doubt that Lucid runs fine with mondrian(we use it in the PAT Project) and also that Lucid runs without any problems with Pentaho(I use it at work). The fact that bi server is throwing a PDI error suggests that some how it has got confused about the data sources, I have to admit that I haven't tried Lucid with Pentaho 3.5. That being said, I don't see why it would be a problem if everything else is working fine.

Sorry I can't be of assistance but at least I can inform you that things should be working and aren't really related to LucidDB, as far as I can tell. I would suggest you check your prd data connection once again.

Cheers

Tom



On Sun 29/11/09 2:06 AM , Richard Smith [hidden email] sent:

Hi Nicholas

Thank you so much for  your reply.
1. Well I tried your first option and unfortunately it didnt work with inserting the single quotes, it just produced the same error message, error while connecting to SQL
Contents of my modrian.jsp file below
***********************************************************
<%@ page session="true" contentType="text/html; charset=ISO-8859-1" %>
<%@ taglib uri="http://www.tonbeller.com/jpivot" prefix="jp" %>
<%@ taglib prefix="c" uri="http://java.sun.com/jstl/core" %>

<%-- uses a dataSource --%>
<%-- jp:mondrianQuery id="query01" dataSource="jdbc/MondrianFoodmart" catalogUri="/WEB-INF/demo/FoodMart.xml" --%>

<%-- uses lucid d--%>
<%-- jp:mondrianQuery id="query01" jdbcDriver="org.luciddb.jdbc.LucidDbClientDriver" jdbcUrl="jdbc:luciddb:http://localhost" jdbcUser="SU2"  catalogUri="/WEB-INF/queries/FoodMart.xml"--%>

<%-- uses a role defined in FoodMart.xml --%>
<%-- jp:mondrianQuery role="California manager" id="query01" jdbcDriver="org.luciddb.jdbc.LucidDbClientDriver" jdbcUrl="jdbc:luciddb:http://localhost" jdbcUser="SU2"  catalogUri="/WEB-INF/queries/FoodMart.xml" --%>

http://localhost" target="_blank">http://localhost</a>;schema=FOODMART" jdbcuser="SU2"  ="" cataloguri="/WEB-INF/queries/FoodMart.xml">
select
  {[Measures].[Unit Sales], [Measures].[Store Cost], [Measures].[Store Sales]} on columns,
  {([Promotion Media].[All Media], [Product].[All Products])} ON rows
from Sales
where ([Time].[1997])

Test Query uses Mondrian OLAP

2. With respect your second option of setting up JNDI datasource within tomcat, I wast really wasnt sure where to set that, particularly as I was using  theTomcat instance which comes installed  with Pentaho BI. I tried to install Tomcat's 5.5 admin tool,
which allows you to set everything through a web gui but couldnt get that to work either. I even tried to install mondrian in another environment which has Tomcat 6, but that proved to be equally as challenging.

I decided to leave Modrian talking with Lucid outside of pentaho for now and return  to attempting to get Lucid to speak to Modrian inside pentaho BI-Server as you observed in your reply.

I have set up the following
- updated biserver-ce/tomcat/webapps/pentaho/WEB-INF/web.xml file
- updated biserver-ce/tomcat/webapps/pentaho/META-INF/context.xml
- Logged into Administration Console
- Added the new datasource linked to Lucid Pressed the test button and voila success everything tested ok
- The Datasource now appears in the valid list of Datasources within Admin Console

- Logged into the BIServer as Joe (Admin)
-Go to define a new report
-Go to select Data Source
-Add a New Data source, a connection list appears with Lucid datasource that was successfully tested within admin-console
- I highlight the new Lucid Datasource and press edit connection, all of the settngs that appeared in the admin-console appear here . I also notice that it defaults to generic database in the connection type
- I press Test and unfortunately hit another error

"Error connecting to database [lucidfm] : org.pentaho.di.core.exception.KettleDatabaseException:
"Error occured while trying to connect to the database
"Exception while loading class
"org.pentaho.di.core.exception.KettleDatabaseException:
"Error occured while trying to connect to the database
"Exception while loading class
"at org.pentaho.di.core

- I reboot the server and restart everything again and still get the error message...So Im scratching my head thinking this works in the admin console but not in the BI Server.
Just to make sure I dont have a flaky Pentaho BI server install, I test all the other datasources which are connected to MySQL and Hypersonic they all work and I can run  SQL statements within the preview area.
So Im faced which another issue with Lucid.

Im kinda of stuck now because I cant even get Lucid to play nice with the mondrian schema workbench client too so I cant publish a schema file to the BI server, which means no analysis views on Lucid.
That strange inability to browse tables  using  JDBC explorer functionality. It shows the Schema eg. Foodmart...then the tables (Customer, Department , inventory_fact_1997 etc, then stops. With foodmart in Mysql you can browse down to the table columns)

I would be very greatful if anybody could point me in the right direction as regards Lucid  connection anomolies..Any Successfully working connection settings are greatfully recieved
Thank you again Richard

 



------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
luciddb-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/luciddb-users
Loading...